1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Diskussion zu Ambilight ohne löten

Discussion in 'German Talk' started by Brindosch, 21 May 2016.

  1. Brindosch

    Brindosch Administrator Administrator

    Messages:
    679
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Alles Fragen/Anregungen/Probleme hier rein
    Danke
     
  2. Elles

    Elles New Member

    Messages:
    1
    Hardware:
    RPi2
    Hallo und guten Tag,
    ich bin hier absoluter Neuling und beschäftige mich erst seit gestern mit dem Nachbau eines Ambilights. Bin durch das ausführliche Tutorial auf diese Seite gestoßen. Nun habe ich zunächst eine Frage:
    Es wird gesagt, dass das beschriebene System auf 100 LEDs beschränkt ist wegen des Stroms. Welche LEDs werden denn empfohlen, wenn ich jetzt einen 60 Zoll Fernseher mit Ambilight nachrüsten möchte? Überschlagen habe ich mal jetzt mit ca. 4 Meter LED Streifen gerechnet, das wären ja dann schon 128 LEDs und demnach zuviel.
    Vielen Dank schon einmal im Vorraus
     
  3. Brindosch

    Brindosch Administrator Administrator

    Messages:
    679
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Hallo Elles,
    am Besten: Sofern du auf einen Lötkolben zurückgreifen kannst, löte die Ecken einfach so zusammen, ist jeweils eine 1:1 Verbindung. Also 5V mit 5V, Do mit Di, Ci mit Co und Gnd mit Gnd
    (Niemals Ci mit Ci oder Co mit Co oder Ci mit Ci oder Di mit Di - dann ist einer deiner Streifen verdreht! (Eingang - Ausgang))
    Schnapp dir dazu eine Leitung mit mindestens 0,5mm² Querschnitt besser 0,75mm²
    https://www.amazon.de/s/ref=nb_sb_noss?__mk_de_DE=ÅMÅŽÕÑ&url=search-alias=aps&field-keywords=0,75mm²+Leitung&rh=i:aps,k:0\c75mm²+Leitung
    Dazu kann man auch einfach Lautsprecherkabel nehmen.

    Für die Verbindung zum Pi und Stromversorgung nimmst du anstatt den Federzug klemmen einfach auch den Lötkolben zur Hand und jeweils zusammen löten anstatt sie in den Verbinder zu stecken.
    Tipp: Entweder danach jeweils tape drum herum oder besser und schicker: Einen Schrumpfschlauch zur Isolation.
    https://www.amazon.de/s/ref=nb_sb_noss_2?__mk_de_DE=ÅMÅŽÕÑ&url=search-alias=aps&field-keywords=schrumpfschlauch+sortiment&rh=i:aps,k:schrumpfschlauch+sortiment

    Fertig.
    Damit spart man sogar etwas Geld. Da du dann die Eckverbinder nicht benötigst und die Federzugklemmen.



    Viel Spaß!
     
    Last edited: 22 June 2016
  4. Wastl

    Wastl New Member

    Messages:
    17
    Hardware:
    RPi2, RPi3, +PhilipsHue
    Was ist denn hier der Flaschenhals? Die Eckverbinder etwa?
    Beim Lightberry-Kit waren so selbstklebende Winkel dabei, damit man den LED-Strip nach außen gedreht (nicht nach hinten gerichtet) um den TV-Rand legen kann. Dadurch muss man den Streifen an den Ecken auch nicht abschneiden und Verbindungen schaffen. Ist das nicht die sicherste Lösung?
     
  5. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    942
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    Jap der Eckverbinder... Sicher ist immer löten, nur liegt das nicht jedem oder nicht jeder hat einen Lötkolben
     
  6. Zweistein

    Zweistein New Member

    Messages:
    9
    Hardware:
    RPi3
    Hallo zusammen,
    an dieser Stelle auch nochmal: Vielen Dank für das coole Tutorial - kombiniert mit den Erweiterungen für externe Quellen (USB Grabber/HDMI Splitter) hat mich das in nullkommanix an den Start gebracht. (Lötkolben-schwingen ist so ziemlich das Einzige wo ich gern ein bisschen bequem bin :) )

    Bei mir funktioniert der Spaß übrigens mit 120 LEDs am 55'' TV sehr gut, trotz der lötfreien Bauweise. Ich habe allerdings die Federzugklemmen durch "normale" Lüsterklemmen ersetzt, hat sich als etwas dauerhafter erwiesen wenn man mal an den Kabeln rumfrickeln muss. Alle Kabel der LED-Stränge sind hinter dem TV in einer vierfach-Klemme zusammengefasst und dann mit ein paar losen Drähten (sollte eigentlich ein Cat5 Kabel sein aber es sollte schnell gehen) in den Hifi-Schrank geführt wo der ganze restliche Elektronikspaß rumliegt (das Chaos harrt noch seiner Auflösung)

    Stromtechnisch jedenfalls keinerlei Probleme, das vorgeschlagene Netzteil hat auch den gesamten 5m-Strang (160 LEDs) problemlos zum leuchten gebracht - ich hoffe nur dass es das auch bei Dauerlast tut.

    Die Eckverbinder-Kabel fand ich übrigens recht fummelig, da sie standardmäßig als Flachband kommen - musste ich erst auftrennen damit sie sich zumindest einigermaßen an den TV schmiegen wollten (mit Tesa) - schön ist noch anders, die flachen Eckverbinder die man auf Amazon findet sind aber zu schmal (wären sonst toll) also werd ich da nochmal umfriemeln oder - wenn alles nichts nützt - gelegentlich doch zum Brateisen greifen müssen... die Verbindung als solche ist jedenfalls zuverlässig.

    Was mich aktuell noch fuchst ist die Abstimmung der Beleuchtung bei "schwarzen Balken" (die sollen ignoriert werden, das klappt momentan am unteren Bildrand besser als oben - ist wohl Feintuning-Sache) und eine leichte "Unruhe" in der Beleuchtung bei stehenden Bildern von bestimmten Quellen (Desktop-Hintergrund vom Mac mini oder Bildschirmschoner vom FireTV) - aber dafür dass das Ganze in netto unter 2 Stunden fertig montiert, eingerichtet und ausprobiert war kann man nicht meckern - und ein TV mit Original-Ambilight hätte deutlich mehr gekostet und nicht so schön geleuchtet.

    Bin schon gespannt, wie oft ich am Wochenende "bauste mir auch so eins?" zu hören kriege...

    Danke!
    Jerry
     
    • Like Like x 2
  7. Brindosch

    Brindosch Administrator Administrator

    Messages:
    679
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Super freut mich!
    Ich dachte schon da sich lange nichts getan hat an Rückmeldung es ist mist :)
    Ja die Verbinder sind nicht unbedingt spitze und die Klemme definitiv "nur im geschützten Bereich, nicht berühren oder ziehen" :)
    Je nach Feedback lässt sich das aber entsprechend verbessern soweit möglich :)

    Ich befürchte das unruhige Bild kommt von deinem Splitter oder Converter. Wegen den Rändern, das Bild sollte "gut" beschnitten werden, so das es wirklich saubere Ränder hat (oft stark verschwommen) und kein Schwarz mehr darauf zu erkennen ist. Das könnte vielleicht auch mit dem Flimmern zusammen hängen.
    Ansonsten mal die Schwelle manipulieren für den Rand.

    Viel Spaß bei der Bandarbeit :)
    LG
    brindosch

    PS. Ich würde gerne Bilder der Community sammeln die das ganze in Aktion zeigen in einer Art "community gallery". So als zum Herzeigen für alle, was sie sich darunter vorstellen können. Solltest du Lust haben würde ich mich freuen über ein paar ausgewählte Bilder :)
     
  8. Zweistein

    Zweistein New Member

    Messages:
    9
    Hardware:
    RPi3
    Ich überrede mein Schlauphon mal, ein paar brauchbare Bilder zu machen sobald ich das Flimmern im Griff habe - dann sehr gerne :)

    Ich sah grad in der HyperCon Anleitung, dass man tatsächlich Testbilder vom Grabber runterladen kann - ich denke das teste ich heute abend mal an (wieder so'n Tag wo man das Ende der Arbeitszeit nicht abwarten mag...)

    LG
    Jerry
     
  9. Zweistein

    Zweistein New Member

    Messages:
    9
    Hardware:
    RPi3
    So nach einigem Feintuning (wie unter "Software Support" geschrieben klappt leider das Save/Load der Settings in HyperCon nicht wirklich) hab ich die Randproblematik im Griff - alles schick.

    Die Unruhe bleibt bei einigen Quellen noch und die Farben sind auch nicht ideal (zu intensiv - mal sehen an welchen Stellschrauben ich da drehen muss). Sieht aber trotzdem schon sehr schön aus. Fotos folgen in Kürze.

    Was ich seltsam fand - in einem Tutorial stand was, man solle das Videoformat auf "NTSC" stellen (was auch vorbelegt war) - bei mir funktioniert's mit "PAL" besser (was an sich auch logisch sein sollte) - spannend wird's noch wenn ich meinem LD Player erlaube, NTSC-LDs nativ abzuspielen (der kann zum Glück auch PAL Umwandlung...) aber der Test kommt erst am Wochenende, zu wenig Zeit im Moment.

    LG
    Jerry
     
  10. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    942
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    die schalter sind sehr oft falsch beschrieben! falls du das meinst..
     
  11. Zweistein

    Zweistein New Member

    Messages:
    9
    Hardware:
    RPi3
    So, nun hab ich einiges an Kabel-Debugging durch (u.a. ein fehlerhaftes HDMI-Kabel identifiziert - was man nicht so alles findet...) und die Geschichte läuft ziemlich rund.
    Etwas an der Farbtemperatur drehen könnte man noch, was aber durch den Load/Save-Bug in HyperCon aktuell sehr mühselig ist, es sei denn man zieht das Tuning komplett in einer Session durch (wofür aber außerhalb des Urlaubs noch die Zeit fehlt - also wohl erst nächste Woche :) )

    Getestet aktuell jedenfalls mit BluRay/DVD, FireTV, AppleTV, Mac mini in FullHD und - ta-dah! - LaserDisc; letzteres funktioniert prima dank Upscaler in meinem Yamaha RX-V671 nachdem ich der Kiste ein Firmware-Update verordnet hatte). Ich hab allerdings noch ein paar historische NTSC-LDs - deren Testlauf steht noch aus, ich könnte mir vorstellen dass die Geschichte da noch Schwächen zeigt.

    Das leichte Flimmern der LEDs bei Mac Desktop oder FireTV Menü Standbild ist leider geblieben - da ansonsten keinerlei Störungen erkennbar sind, bin ich da etwas ratlos. Selbst die Erkennung schwarzer Ränder (Cinemascope-Balken und 4:3-Seitenränder) klappt zuverlässig und die Farbspiele sind da wo sie hingehören.

    Echt klasse - hätte ich viel eher machen sollen :)

    Frage noch: Ich fand auf Amazon dieses hier: HDMI-Splitter mit FBAS

    Aktuell nutze ich die "Puzzle-Lösung" aus separatem HDMI-Splitter und HDMI-Analog-Wandler - diese 2-in-1-Lösung scheint mir eleganter. Hat das schon jemand getestet und evtl. Einschränkungen festgestellt? (Bei dem Preis nicht ganz unerheblich - ist das Ding doch teurer als die Bastelvariante aus zwei Geräten selbst incl. zusätzlich notwendiger Kabel - und da weiss ich zumindest dass es in allen Auflösungen funktioniert)

    Da der HDMI-Splitter ständig unter Strom stehen muss und ich dem RasPi auch noch andere Jobs zugedacht habe, soll auf Dauer nur der Strom der LED-Streifen (separates 5V-Netzteil) abgeschaltet werden - dabei fällt auf, dass einige LEDs auch bei ausgeschalteter Spannungsversorgung gelegentlich unmotiviert aufblinken - ist das anderen auch schon passiert?

    LG
    Jerry
     
  12. visionsurfer

    visionsurfer Member

    Messages:
    34
    Hardware:
    RPi3, +PhilipsHue
    @Brindosch

    Tausend Dank für dein tolles Tutorial. Ich bin gerade dabei alles zu besorgen. Leider geht dein Link nicht mehr zu den Federzugklemmen. Hast du einen Link wo man noch welche bekommen kann. Ich finde bei Ebay oder Amazon nichts richtiges. Oder kann man auch so WAGO 222-415 Verbindungsklemme, 5 Pole klemmen nehmen ?

    Ich möchte gerne das von dir beschriebene LED Projekt realisieren, aber zusätzlich das ganze dann noch mit so 2 IRIS Lampen von Philips HUE erweitern. Das Material und die ganzen Sachen von Philips inkl. Bridge ist schon vorhanden. Ich hoffe das geht ?

    Würde mich freuen von dir zu hören.

    Grüße,
    Visionsurfer
     
  13. Zweistein

    Zweistein New Member

    Messages:
    9
    Hardware:
    RPi3
    Moin,
    aus eigener Erfahrung - die WAGO Klemmen sind für E-Installationen - die Kabel die hier im Spiel sind sind zu dünn dafür und würden vmtl. nicht dauerhaft halten. Ich habe ganz simple Lüsterklemmen genommen und es funktioniert prima - man muss halt 'n Schraubendreher bemühen, die Federzugklemmen sind vmtl. etwas bequemer in der Handhabung.
    LG
    Jerry
     
  14. visionsurfer

    visionsurfer Member

    Messages:
    34
    Hardware:
    RPi3, +PhilipsHue
    Hi,

    ok. Danke für die Info. Dann werde ich es wohl damit versuchen.

    Kurz noch eine andere Frage:

    In dem Projekt ist ja beschrieben wie ich das mit dem LED´s mache.

    Gibt es zufällig irgendwo noch ein Tutorial wie ich dann zusätzlich zu den LED´s am Fernseher noch mein Philips HUE System verbinden kann ?

    Grüße,
    Visionsurfer
     
  15. Toni

    Toni New Member

    Messages:
    3
    Hardware:
    RPi3
    Hallo an die Runde. Mein erster Post und schon gleich ne Frage wofür ich sicher gesteinigt werde.

    Es ist eigentlich nur eine Grundsatzfrage. Funktioniert das Ambilight nur mit Material was ich über dem Pi3 einspeise oder auch mit anderen Quellen? (bei mir läuft praktisch alles über den AVR zum TV)

    Ach und ganz nebenbei, Ich bin Toni 38 und wahlschweizer :p Soviel der Volständigkeit halber ;)
     
  16. Starbix

    Starbix Pukinator

    Messages:
    63
    Hardware:
    RPi1/Zero, RPi3, +Arduino
  17. Brindosch

    Brindosch Administrator Administrator

    Messages:
    679
    Hardware:
    RPi1/Zero, RPi2, RPi3, +nodeMCU/ESP8266
    Du bist geflüchtet? :)

    Wie @Cédric Laubacher bereits erwähnte, du kannst über einen usb grabber der wiederum von einem hdmi splitter mit bildern versorgt wird einspeisen :)
    Bist du schon mit 4K unterwegs?

    @TPmodding
    Link_to_Tut
     
  18. Toni

    Toni New Member

    Messages:
    3
    Hardware:
    RPi3
  19. Starbix

    Starbix Pukinator

    Messages:
    63
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    Das muss es auch nicht.
    Wenn du ein AV ausgang bei deinem AV Receiver hast, brauchst du nur noch ein USB grabber.
     
  20. visionsurfer

    visionsurfer Member

    Messages:
    34
    Hardware:
    RPi3, +PhilipsHue
    Hallo,

    kurze Frage. Wie ist es möglich mit der Software 2 Konfigurationen zu erstellen ?

    Ich möchte zum einen die LED´s direkt hinter dem Fernseher aus dem Tutorial steuern und zusätzlich gerne noch rechts und links zwei Philips HUE Lampen als Erweiterung.

    Irgendwo hab ich mal gelesen das man dazu 2 Konfigs erstellen muss. Wie bekomme ich dann beide erstellt und auf den Raspberry übertragen, so das beide gleichzeitig laufen ?

    Grüße,
    Visionsurfer