1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Philips HUE zu dunkel

Discussion in 'German Talk' started by firstfacility, 20 November 2016.

  1. firstfacility

    firstfacility New Member

    Messages:
    3
    Hallo Leute,

    ich hätte meine HUE´s gerne etwas heller, also nicht nur den Weisswert sondern alles. Meine Config hierzu schaut zur Zeit so aus:

    Code:
    // COLOR CALIBRATION CONFIG
            "color" :
            {
                    "channelAdjustment" :
                    [
                            {
                                    "id"   : "default",
                                    "leds" : "*",
                                    "pureRed" :
                                    {
                                            "redChannel"            : 255,
                                            "greenChannel"          : 0,
                                            "blueChannel"           : 0
                                    },
                                    "pureGreen" :
                                    {
                                            "redChannel"            : 0,
                                            "greenChannel"          : 255,
                                            "blueChannel"           : 0
                                    },
                                    "pureBlue" :
                                    {
                                            "redChannel"            : 0,
                                            "greenChannel"          : 0,
                                            "blueChannel"           : 255
                                    }
                            }
                    ],
                    "temperature" :
                    [
                            {
                                    "id"   : "default",
                                    "leds" : "*",
                                    "correctionValues" :
                                    {
                                            "red"   : 255,
                                            "green" : 255,
                                            "blue"  : 255
                                    }

    Das ganze läuft auf einem Rpi. Hätte jemand eine Idee wie ich das heller bekomme ?

    Gruß
    Frank
     
  2. Paulchen-Panther

    Paulchen-Panther Member Developer

    Messages:
    109
    Bitte die ganze config. Danke
     
  3. Maddis

    Maddis n00B

    Messages:
    14
    Hardware:
    RPi3, +PhilipsHue
    der anfrage schliesse ich mich gleich mal an:

    config
    Code:
    // Automatically generated configuration file for Hyperion ambilight daemon
    // Notice: All values are explained with comments at our wiki: wiki.hyperion-project.org (config area)
    // Generated by: HyperCon (The Hyperion deamon configuration file builder)
    // Created with HyperCon V1.03.1 (11.06.2016)
    
    {
      // DEVICE CONFIGURATION
      "device" :
      {
      "name"  : "MyHyperionConfigHUE",
      "type"  : "philipshue",
      "output"  : "192.168.178.2",
      "switchOffOnBlack"  : true,
      "username"  : "my_user",
      "colorOrder" : "rgb"
      },
    
      // COLOR CALIBRATION CONFIG
      "color" :
      {
      "channelAdjustment" :
      [
      {
      "id"  : "default",
      "leds" : "*",
      "pureRed" :
      {
      "redChannel"  : 255,
      "greenChannel"  : 0,
      "blueChannel"  : 0
      },
      "pureGreen" :
      {
      "redChannel"  : 0,
      "greenChannel"  : 255,
      "blueChannel"  : 0
      },
      "pureBlue" :
      {
      "redChannel"  : 0,
      "greenChannel"  : 0,
      "blueChannel"  : 255
      }
      }
      ],
      "temperature" :
      [
      {
      "id"  : "default",
      "leds" : "*",
      "correctionValues" :
      {
      "red"  : 255,
      "green" : 255,
      "blue"  : 255
      }
      }
      ],
      "transform" :
      [
      {
      "id"  : "default",
      "leds" : "*",
      "hsv" :
      {
      "saturationGain"  : 2.0000,
      "luminanceGain"  : 1.0000,
      "luminanceMinimum"  : 0.0000
      },
      "red" :
      {
      "threshold"  : 0.0000,
      "gamma"  : 2.5000
      },
      "green" :
      {
      "threshold"  : 0.0000,
      "gamma"  : 2.5000
      },
      "blue" :
      {
      "threshold"  : 0.0000,
      "gamma"  : 2.5000
      }
      }
      ],
      // SMOOTHING CONFIG
      "smoothing" :
      {
      "type"  : "linear",
      "time_ms"  : 100,
      "updateFrequency" : 5.0000,
      "updateDelay"  : 0
      }
      },
    
      // NO V4L2 GRABBER CONFIG
      // JSON SERVER CONFIG
      "jsonServer" :
      {
      "port" : 19446
      },
    
      // PROTO SERVER CONFIG
      "protoServer" :
      {
      "port" : 19447
      },
    
      // EFFECT PATH
      "effects" :
      {
      "paths" :
      [
      "/storage/hyperion/effects",
      "/usr/share/hyperion/effects"
      ]
      },
    
      // NO FRAME GRABBER CONFIG
      // NO BLACKBORDER CONFIG
      // NO KODI CHECK CONFIG
      // NO BOOTEFFECT CONFIG
      // NO BOBLIGHT SERVER CONFIG
      // NO JSON/PROTO FORWARD CONFIG
    
      // LED CONFIGURATION
      "leds" :
      [
      {
      "index" : 0,
      "hscan" : { "minimum" : 0.0000, "maximum" : 0.2000 },
      "vscan" : { "minimum" : 0.0000, "maximum" : 0.3000 }
      },
      {
      "index" : 1,
      "hscan" : { "minimum" : 0.8000, "maximum" : 1.0000 },
      "vscan" : { "minimum" : 0.0000, "maximum" : 0.3000 }
      }
      ],
    
      "endOfJson" : "endOfJson"
    }
    
    besonders bei rot und blau sind die HUE fast "duster". ich hatte schon etwas experimentiert, daher nicht über die "transform-parameter" wundern...gebracht hats nichts.

    zur info: ruft man die HUE-App zwischenzeitlich auf, so ist die helligkeit dort auf minimum bei den lampen angezeigt.
    via APP die helligkeit hoch -> ok, hyperion gestartet -> lichter werden "duster", in der HUE-App stehen die regler wieder ganz links (also minimum).

    woran kann es liegen?


    mfg mad :)
     
  4. Paulchen-Panther

    Paulchen-Panther Member Developer

    Messages:
    109
    Schalte mal die Smoothing Option auf None. Hab leider keine hue hier um das zu testen.
     
  5. Maddis

    Maddis n00B

    Messages:
    14
    Hardware:
    RPi3, +PhilipsHue
    ohne smoothing reagieren die HUE absolut verzögert (die bridge kann wohl nur ne bestimmte anzahl von anweisungen die sekunde ab). heller werden sie aber ohne sowie mit smoothing-option definitiv nicht...leider...alles schon getestet.

    *edit: eben nochmal ohne smoothing getestet -> keine besserung
    gibt es vllt eine "nicht berücksichtigte variable" bezüglich der helligkeit bei den HUE?

    *edit2: lt. HUE API gibbet den parameter "bri" für brightness. von 0 bis 254. wird der berücksichtigt?

    gruss mad
     
    Last edited: 3 December 2016
  6. Paulchen-Panther

    Paulchen-Panther Member Developer

    Messages:
    109
    ich schau mal nach
     
    • Like Like x 1
  7. Paulchen-Panther

    Paulchen-Panther Member Developer

    Messages:
    109
    Ja der Parameter wird berücksichtigt. Siehe hier: https://github.com/hyperion-project...libsrc/leddevice/LedDevicePhilipsHue.cpp#L114

    Was du noch machen könntest ist ntim über Github oder hier im Forum anschreiben und ihn um Hilfe bitten. Er hat die Hue Lampen implementiert. Leider kann ich dir nicht viel helfen in der Hinsicht, zwecks fehlender HUE Lampen. Sorry.
     
  8. Maddis

    Maddis n00B

    Messages:
    14
    Hardware:
    RPi3, +PhilipsHue
    yo, ich danke dir erstmal für die recherche...mal schauen, was wir erreichen können.


    :)
     
    • Like Like x 1
  9. Maddis

    Maddis n00B

    Messages:
    14
    Hardware:
    RPi3, +PhilipsHue
    um das thema wieder etwas aufzuwärmen:

    der gute ntim hat sich leider seit mitte letzten jahres hier nimmer "blicken" lassen, hat daher natürich nicht die profilnachricht bezüglich dieses thread gelesen / lesen können... :(

    könnte ihn evtl jemand auf github anschreiben? ich möchte mich ungern nur für ne nachricht dort extra reggen...


    thx
     
  10. MI5CHK4

    MI5CHK4 New Member

    Messages:
    4
    Hardware:
    RPi2, +PhilipsHue
    @Maddis,
    in deiner config sehe ich keine ""transitiontime" .
    Meine Hue´s leuchten normal hell (6 Stück), aber etwas verzögert :(
    Code:
    // Automatically generated configuration file for Hyperion ambilight daemon
    // Notice: All values are explained with comments at our wiki: wiki.hyperion-project.org (config area)
    // Generated by: HyperCon (The Hyperion deamon configuration file builder)
    // Created with HyperCon V1.03.1 (11.06.2016)
    
    {
        // DEVICE CONFIGURATION
        "device" :
        {
            "name"       : "MyHyperionConfig",
            "type"       : "philipshue",
            "output"     : "192.168.XXX",
            "transitiontime"     : 3,
            "switchOffOnBlack"     : true,
            "username"     : "newdeveloper",
            "colorOrder" : "rgb"
        },
    
        // COLOR CALIBRATION CONFIG
        "color" :
        {
            "channelAdjustment" :
            [
                {
                    "id"   : "default",
                    "leds" : "*",
                    "pureRed" :
                    {
                        "redChannel"        : 255,
                        "greenChannel"        : 0,
                        "blueChannel"        : 0
                    },
                    "pureGreen" :
                    {
                        "redChannel"        : 0,
                        "greenChannel"        : 255,
                        "blueChannel"        : 0
                    },
                    "pureBlue" :
                    {
                        "redChannel"        : 0,
                        "greenChannel"        : 0,
                        "blueChannel"        : 255
                    }
                }
            ],
            "temperature" :
            [
                {
                    "id"   : "default",
                    "leds" : "*",
                    "correctionValues" :
                    {
                        "red"     : 255,
                        "green"    : 255,
                        "blue"     : 255
                    }
                }
            ],
            "transform" :
            [
                {
                    "id"   : "default",
                    "leds" : "*",
                    "hsl" :
                    {
                        "saturationGain"    : 1.0000,
                        "luminanceGain"        : 1.0000,
                        "luminanceMinimum"        : 0.0000
                    },
                    "red" :
                    {
                        "threshold"     : 0.0000,
                        "gamma"         : 2.5000
                    },
                    "green" :
                    {
                        "threshold"     : 0.0000,
                        "gamma"         : 2.5000
                    },
                    "blue" :
                    {
                        "threshold"     : 0.0000,
                        "gamma"         : 2.5000
                    }
                }
            ]
        // NO SMOOTHING CONFIG
        },
    
        // V4L2 GRABBER CONFIG
        "grabber-v4l2" :
        {
            "device" : "/dev/video0",
            "input" : 0,
            "standard" : "PAL",
            "width" : -1,
            "height" : -1,
            "frameDecimation" : 2,
            "sizeDecimation" : 8,
            "priority" : 900,
            "mode" : "2D",
            "cropLeft" : 15,
            "cropRight" : 15,
            "cropTop" : 15,
            "cropBottom" : 15,
            "redSignalThreshold" : 0.0,
            "greenSignalThreshold" : 0.1,
            "blueSignalThreshold" : 0.1
        },
    
        // BLACKBORDER CONFIG
        "blackborderdetector" :
        {
            "enable" : true,
            "threshold" : 0.0,
            "unknownFrameCnt" : 600,
            "borderFrameCnt" : 50,
            "maxInconsistentCnt" : 10,
            "blurRemoveCnt" : 1,
            "mode" : "default"
        },
    
        // BOOTEFFECT CONFIG
        "bootsequence" :
        {
            "color" : [0,0,0],
            "effect" : "Rainbow swirl fast",
            "duration_ms" : 3000,
            "priority" : 700
        },
    
        // JSON SERVER CONFIG
        "jsonServer" :
        {
            "port" : 19444
        },
    
        // PROTO SERVER CONFIG
        "protoServer" :
        {
            "port" : 19445
        },
    
        // EFFECT PATH
        "effects" :
        {
            "paths" :
            [
                "/storage/hyperion/effects",
                "/usr/share/hyperion/effects"
            ]
        },
    
        // NO FRAME GRABBER CONFIG
        // NO KODI CHECK CONFIG
        // NO BOBLIGHT SERVER CONFIG
        // NO JSON/PROTO FORWARD CONFIG
    
        // LED CONFIGURATION
    ^    "leds" :
        [
            {
                "index" : 0,
                "hscan" : { "minimum" : 0.2500, "maximum" : 0.5000 },
                "vscan" : { "minimum" : 0.9000, "maximum" : 1.0000 }
            },
            {
                "index" : 1,
                "hscan" : { "minimum" : 0.0000, "maximum" : 0.2500 },
                "vscan" : { "minimum" : 0.9000, "maximum" : 1.0000 }
            },
            {
                "index" : 2,
                "hscan" : { "minimum" : 0.7500, "maximum" : 1.0000 },
                "vscan" : { "minimum" : 0.9000, "maximum" : 1.0000 }
            },
            {
                "index" : 3,
                "hscan" : { "minimum" : 0.5000, "maximum" : 0.7500 },
                "vscan" : { "minimum" : 0.9000, "maximum" : 1.0000 }
            },
            {
                "index" : 4,
                "hscan" : { "minimum" : 0.0000, "maximum" : 0.2500 },
                "vscan" : { "minimum" : 0.0000, "maximum" : 0.1000 }
            },
            {
                "index" : 5,
                "hscan" : { "minimum" : 0.7500, "maximum" : 1.0000 },
                "vscan" : { "minimum" : 0.0000, "maximum" : 0.1000 }
            }
        ],
    
        "endOfJson" : "endOfJson"
    }
     
  11. Maddis

    Maddis n00B

    Messages:
    14
    Hardware:
    RPi3, +PhilipsHue
    alles schon probiert, hilft nix...ich denke auch nicht, dass eine transitiontime da mittelbar einfluss hätte (da es sich hier um eine "verzögerung" handelt. bei mir steht sie auf "0" (oder ich lasse sie halt weg)).

    die "leuchtkraft" bei rot und besonders bei blau ist zu niedrig. man kann das prima in der hue-app erkennen. bei blau ist der helligkeits-regler komplett runter, bei rot auf max ein drittel. (getestet mit referenzbildern)

    es ist dabei auch völlig irrelevant, ob die HUE nun in erster oder zweiter instanz vom daemon angesteuert werden.
     
    Last edited: 7 January 2017
  12. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    943
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    es gibt mir keine bekannte funktion um leute auf github anzuschreiben...müsstes schon dort nen Issue eröffnen...

    (aber ich habe ebeng gesehen der folgt dem git hier https://github.com/craigcabrey/luminance, vllt kann jemand damit was anfangen?)
     
    • Thank you Thank you x 1
  13. ntim

    ntim New Member

    Messages:
    11
    Hardware:
    RPi3, +PhilipsHue
    Hallo,

    Die hue app macht natürlich immer punchy Farben. Ich habe die Umrechnung und von rgb in xyz farbewerte und Helligkeit aus der Entwickler Dokumentation übernommen. Kann gerne jemand überprüfen, habe erst in zwei Wochen wieder zugriff auf meine hue. Für einen simplen Check kannst du ja mal blau und rot in xyz und helligkeitswerte umrechnen und per cgi webinterface setzen.

    Mit freundlichen Grüßen
     
  14. ntim

    ntim New Member

    Messages:
    11
    Hardware:
    RPi3, +PhilipsHue
    • Thank you Thank you x 1
  15. Maddis

    Maddis n00B

    Messages:
    14
    Hardware:
    RPi3, +PhilipsHue
    yo, danke dir erstmal für die rückmeldung...

    wenn ich wieder etwas mehr zeit und raum habe werde ich das mal versuchen zu testen...
     
  16. terrax001

    terrax001 New Member

    Messages:
    17
    Hardware:
    RPi2, +PhilipsHue
    Hallo Maddis, Hallo ntim,
    habe das gleiche Problem wie Maddis, der hue lightstrip plus läuft gut zum ambi mit aber blau und rot bleiben
    recht schwach. Genau wie es Maddis beschrieben hat sieht es auch bei mir auf der Hue app aus.
    Gibt es schon eine Lösung? Gerne mit einer Beschreibung für jemanden der nicht so tief drin steckt.

    thx
     
  17. terrax001

    terrax001 New Member

    Messages:
    17
    Hardware:
    RPi2, +PhilipsHue
    Hallo zusammen,
    keiner eine Lösung?

    Gruß
    Rainer
     
  18. terrax001

    terrax001 New Member

    Messages:
    17
    Hardware:
    RPi2, +PhilipsHue
    Hallo ntim,
    ich habe mir das mit der Umwandlung RGB in xyz mal auf der developers Seite von der Hue angesehen,
    nur komme ich nicht dahinter wie ich die Werte in meiner Hue config ändern soll. Kannst Du hier unterstützen? Es geht
    mir wie Maddis darum mehr Lichtstärke bei rot und blau zu erhalten. Aktuell werden helle Farben auf dem hue "lightstrip plus" recht gut wiedergegeben, sobald aber ein sattes blau, grün oder rot auf dem TV abgegriffen wird, ist dies auf dem lightstrip recht dunkel, dunkler als auf dem Ambilight.

    Gruß
    Rainer
     
  19. terrax001

    terrax001 New Member

    Messages:
    17
    Hardware:
    RPi2, +PhilipsHue
    Hallo zusammen,
    hat jemand einen Rat wie ich die Farben blau und rot heller bekomme? Meine Gamma Werte liegen bei 1 und so schlecht sieht es garnicht aus, halt nur bei blau und rot bleibt die Ausgabe eher schwach.

    Gruß
    Rainer
     
  20. ntim

    ntim New Member

    Messages:
    11
    Hardware:
    RPi3, +PhilipsHue