1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPi + LibreELEC WS2813b ... I'm lost...

Discussion in 'Hardware Support' started by Lugdunoob, 26 September 2018.

  1. Lugdunoob

    Lugdunoob New Member

    Messages:
    3
    Hi All,

    Just trying to move from a first generation lightpack to another system.
    I acquire 5m of ws2813b and followed a lot of tutorials.

    Result is, that the leds are blinking 1 sec when I connect them to the supply and then nothing more...

    Can someone help me :)
     
  2. nach00

    nach00 New Member

    Messages:
    18
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +PhilipsHue
    Did you install Hyperion yet?

    Also, make sure that the wiring is connected on the corrected side. Meaning, the 4 wires coming from the LED strip to the controller is beginning in the correct direction.
     
  3. Lugdunoob

    Lugdunoob New Member

    Messages:
    3
    Hi Nach00, Yes it's installed, I used it with my previous lightpack. How can I check if it's a issue with the power supply or the leds?
    Thanks for your help
     
  4. MaxW

    MaxW New Member

    Messages:
    1
    Hardware:
    RPi3
    Hi Frenchman,

    been there, i can confirm that hyperion is not working correctly with WS2812.After a long journey of testing, i verified that the LEDS are correctly connected by testing it via
    https://github.com/jgarff/rpi_ws281x.

    It seems like it is currently not possible to drive WS2812 directly via raspberry GPIO pins. There is another thread here somewhere discussing that problem too.
    I had some spare ESP8266 microcontroller laying around and was able to fix fixed this problem with it. After installing adalight onto it (https://github.com/dmadison/Adalight-FastLED), connecting it via USB to the raspberry, and the LEDS to the controller, now everything is working fine for me.

    Btw, i just registered to give you this information ;)
     
    • Like Like x 1
  5. gebn

    gebn New Member

    Messages:
    26
    Hardware:
    RPi3, +Arduino
    This is true, but I use a ws2813b cable with a 74hct125 level shifter, works fine. a ws2818b would also work with this
     
  6. Lugdunoob

    Lugdunoob New Member

    Messages:
    3
    Hi gebn...I m more than lost on the ws2813b I have 4 ``pins/wires``` where do I have to connect them. Do you know a tutorial I can follow? Thanks