1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Hyperion always

Discussion in 'Hyperion General' started by JorgeAnzola, 4 October 2020.

  1. JorgeAnzola

    JorgeAnzola New Member

    Messages:
    8
    Ok, so Hyperion is always on cause the capture card is always transmitting something, is there a turn off by inactivity setting or something I could do?

    This is what I'm getting while the HDMI source is off. And of course, I see colored bars in the LED strip :(

    [​IMG]

    I have Hyperion installed on Raspbian on a RPi 4

    My last resource will be a switch/plug controlled by Hassio to remove the power source of the strip, but that's a bit lame. Any idea is very much welcome.

    Thanks a lot
     
  2. Paulchen-Panther

    Paulchen-Panther Moderator Staff Member Developer

    Messages:
    852
    Hardware:
    RPi1/Zero, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
  3. JorgeAnzola

    JorgeAnzola New Member

    Messages:
    8
    I saw those settings, but couldn't figure out how to use them. At the moment my settings are exactly like your screenshot, with the difference that I see an (unchecked) CEC detection checkbox and the size decimation is 8 in mine.
     
  4. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / WS2801 / Hyperion.NG

    Messages:
    99
    Hardware:
    RPi3
    on the webbrowser [8090] you can [disable hyperion] on tab Dashboard, this disables your led,s but service is still running and maybe is a little hassle to do that on tablet or laptop every time.. . or you connect with putty/SSH or VNC and use SSH code below but hassle is still there :)
    i used a workaround before because the autostart service didn't want to execute on my system, so i did it with a phone ( my Rasbian knowledge isn't high)
    so scrolled around on the web and then found a way.

    OPTION;
    you can also try an app Raspberry SSH lite on your tablet/phone, in the app you can program a button with CMD text for turning Hyperion on and off,

    ON
    CMD text; hyperiond

    OFF
    CMD text; sudo killall hyperiond (only works when autostart/restart systemd is NOT active ) otherwise Hyperion will restart after few seconds.

    reboot PI
    CMD text; sudo reboot

    These commands you put into a separate button, this app synchronizes with your services on the Raspi, just use a good local network with same IP range and the same ip adres for every button that you're programming.
    With the OFF command Hyperion should quit completely and therefor also terminating GPIO's output data that should turn off your lights.


    good luck :)
     
  5. zolakk

    zolakk New Member

    Messages:
    3
    Hardware:
    RPi3
    I have the same bars pattern on mine, and turning on "signal detection" with the settings in my attached screenshot fixed it. I don't understand how the values in the HMin, HMax, VMin, and VMax (maybe percentage of width/height?) work but these seem to work best
     

    Attached Files:

    • Like Like x 1
  6. Awawa

    Awawa Active Member

    Messages:
    226
    Hardware:
    RPi1/Zero, RPi3, +nodeMCU/ESP8266
  7. JorgeAnzola

    JorgeAnzola New Member

    Messages:
    8
    Ok, so, I've been testing. Still not there yet, first I liked @jeroen warmerdam 's idea, a bit differently tho, I haven't looked into it deeply cause that's a plan b for me. But sending the commands from Hassio it's probably possible

    sudo systemctl restart [email protected]
    sudo systemctl stop [email protected]

    I've tried @Awawa's settings, VMin=Hmin=0.01, VMax=Hmax=0.1 and 1024x768 with no luck.

    But, based on @zolakk's settings, I don't get the colored bars anymore and the live video is empty, but then I get the background effect always running. So I think with this I'm getting closer but not there yet.

    [​IMG]

    If I set the RGB thresholds to 1, 1, and 100, I get the colored bars back.

    At least my new Plan B is better than automating a smart plug to cut the power of the led strip. But do you guys have something else I might be missing?
     
  8. JorgeAnzola

    JorgeAnzola New Member

    Messages:
    8
    Oh wait! Now it works! I just had to change a few automatic things (Actually based on @Paulchen-Panther's first reply)

    This did the trick for me: Changing the resolution, fps, and the decimation. I'm not if just one of those values fixed the issue or the combination of the three, cause I don't fully get the concept, but now it's working nicely!

    [​IMG]
     
    • Like Like x 3
  9. NeeeeB

    NeeeeB Active Member

    Messages:
    168
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    Hi,
    I have the exact same problem, meaning rainbow bars when my Yamaha receiver is Off...
    And I'm totally unable to get rid of this, even with the previous settings applied (see screenshot).
    [​IMG]

    I'm running the latest Hyperbian on a Pi3.
    What I find strange is that I didn't have this "rainbow bars" when I ran Hyperion.NG alongside Librelec on the same Pi (and signal detection was turned off).

    Any idea ?

    EDIT: fixed, I've had to increase the 3 thresholds to 30% for it to work ^^
    [​IMG]
     
    Last edited: 19 October 2020
  10. Frogro

    Frogro New Member

    Messages:
    28
    Hardware:
    RPi1/Zero, RPi3, +Arduino
    Darf ich mal auf Deutsch nachfragen? Wenn Grabber Regenbogeneffekt liefert und deshalb CEC nicht funktioniert, kann man das Ausschalten über die Signal Detection Einstellungen doch noch hinkriegen?
     
  11. NeeeeB

    NeeeeB Active Member

    Messages:
    168
    Hardware:
    RPi3, +Arduino, +nodeMCU/ESP8266
    English would be better, you can use Google translate if needed.
    Signal detection works OK, I had to play with threshold values for it to detect the loss of signal ;-)
    I figured it by watching the Live feed when my receiver is off, and I noted there were artifacts in the black bar which made Hyperion believe there was still "movement"...So I increased thresholds to "workaround" these artifacts.
     
  12. JorgeAnzola

    JorgeAnzola New Member

    Messages:
    8
    Ok, so indeed after days of testing this was not solved for me. It was acting strange, for example sometimes in dark scenes it will boot the background effect.
    Until I have a bit more free time to find a proper solution, this is my workaround (Very specific for Hassio users, but might be useful for somebody)

    I added the SSH keys so Hassio could execute a shell command without a password in the RPi running Hyperion, and then I added this in my configuration file:


    switch:
    - platform: command_line
    switches:
    hyperion:
    command_on: "ssh -i /root/.ssh/id_rsa -o StrictHostKeyChecking=no [email protected] 'sudo systemctl start [email protected]'"
    command_off: "ssh -i /root/.ssh/id_rsa -o StrictHostKeyChecking=no [email protected] 'sudo systemctl stop [email protected]'"

    Then I'll have this new switch
    [​IMG]

    And I automated turning on and off when the TV is ON