1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hyperion funktioniert plötzlich gar nicht mehr

Discussion in 'German Talk' started by taker-`, 2 December 2019 at 10:02.

  1. taker-`

    taker-` New Member

    Messages:
    13
    Hardware:
    RPi3, 32/64bit
    hallo,

    hatte mein ambilight jetzt locker 3 monate am laufen und plötzlich geht nichts mehr. also keine einzigste led leuchtet.
    habe nun mal alles außernander genommen und überprüft. konnte auf den ersten blick nun nichts fehlerhaftes feststellen.

    habe folgendes versucht:
    - mit ssh auf den pi3b zu kommen (libreelec) - geht
    - hypercon mit pi kommunizieren lassen und software nochmal neu aufgespielt - geht
    - gesteckte kabel von grabber, converter überprüft - passt, nichts locker oder sonstiges

    log von hypercon:
    Code:
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi systemd[1]: Started Hyperion Systemd service.
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: Hyperion Ambilight Deamon (12857)
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         Version   : V1.03.4 (brindosch-c750c41/dc6a602-1522918225
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         Build Time: Apr  5 2018 01:57:25
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: INFO: Selected configuration file: /etc/hyperion/hyperion.config.json
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: HYPERION INFO: ColorTransform 'default' => [0; 107]
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: HYPERION INFO: ColorCorrection 'default' => [0; 107]
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: HYPERION INFO: ColorAdjustment 'default' => [0; 107]
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: LEDDEVICE INFO: configuration:
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: {
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         "colorOrder" : "bgr",
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         "name" : "MyHyperionConfig",
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         "output" : "/dev/spidev0.0",
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         "rate" : 1000000,
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]:         "type" : "apa102"
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: }
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: INFO: Creating linear smoothing
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: HYPERION (CS) INFO: Created linear-smoothing(interval_ms=50;settlingTime_ms=200;updateDelay=0
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: EFFECTENGINE INFO: 27 effects loaded from directory /usr/share/hyperion/effects
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: EFFECTENGINE INFO: Initializing Python interpreter
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: INFO: Hyperion started and initialised
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: INFO: Boot sequence 'Rainbow swirl fast' EFFECTENGINE INFO: run effect Rainbow swirl fast on channel 0
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: started
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: INFO: Json server created and started on port 19444
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: INFO: Proto server created and started on port 19445
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: width=720 height=576
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: pixel format=YUYV
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:32:07 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: signal threshold set to: {0,0,0}
    ssh in:     Dec 02 09:32:08 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: started
    ssh in:     Dec 02 09:32:08 hyperionsawzraspi hyperiond[12857]: INFO: V4L2 grabber created and started
    ssh in:     Dec 02 09:32:08 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: stopped
    ssh in:     Dec 02 09:32:16 hyperionsawzraspi hyperiond[12857]: EFFECTENGINE INFO: effect finished
    ssh in:     Dec 02 09:32:16 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: started
    ssh in:     Dec 02 09:32:26 hyperionsawzraspi hyperiond[12857]: JSONSERVER INFO: New connection
    ssh in:     Dec 02 09:32:26 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:32:26 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:32:29 hyperionsawzraspi hyperiond[12857]: JSONSERVER INFO: Connection closed
    ssh in:     Dec 02 09:32:29 hyperionsawzraspi hyperiond[12857]: JSONSERVER INFO: New connection
    ssh in:     Dec 02 09:32:29 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:32:29 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:32:29 hyperionsawzraspi hyperiond[12857]: BORDER SWITCH REQUIRED!!
    ssh in:     Dec 02 09:32:29 hyperionsawzraspi hyperiond[12857]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    ssh in:     Dec 02 09:32:36 hyperionsawzraspi hyperiond[12857]: JSONSERVER INFO: New connection
    ssh in:     Dec 02 09:32:36 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:32:36 hyperionsawzraspi hyperiond[12857]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:32:36 hyperionsawzraspi hyperiond[12857]: V4L2GRABBER INFO: stopped
    ssh in:     Dec 02 09:32:59 hyperionsawzraspi hyperiond[12857]: JSONSERVER INFO: Connection closed
    ssh in:     Dec 02 09:33:11 hyperionsawzraspi hyperiond[12857]: JSONSERVER INFO: Connection closed
    ssh in:     Dec 02 09:34:08 hyperionsawzraspi hyperiond[12857]: INFO: Application closed with code 0
    ssh in:     Dec 02 09:34:08 hyperionsawzraspi hyperiond[12857]: EFFECTENGINE INFO: Cleaning up Python interpreter
    ssh in:     Dec 02 09:34:08 hyperionsawzraspi systemd[1]: Stopping Hyperion Systemd service...
    ssh in:     Dec 02 09:34:09 hyperionsawzraspi systemd[1]: Stopped Hyperion Systemd service.
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi systemd[1]: Started Hyperion Systemd service.
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: Hyperion Ambilight Deamon (13130)
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         Version   : V1.03.5 (GitHub-66bef6b/fb413cd-1566231780
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         Build Time: Aug 25 2019 10:39:29
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: Selected configuration file: /etc/hyperion/hyperion.config.json
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: HYPERION INFO: ColorTransform 'default' => [0; 107]
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: HYPERION INFO: ColorCorrection 'default' => [0; 107]
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: HYPERION INFO: ColorAdjustment 'default' => [0; 107]
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: LEDDEVICE INFO: configuration:
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: {
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         "colorOrder" : "bgr",
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         "name" : "MyHyperionConfig",
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         "output" : "/dev/spidev0.0",
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         "rate" : 1000000,
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]:         "type" : "apa102"
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: }
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: Creating linear smoothing
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: HYPERION (CS) INFO: Created linear-smoothing(interval_ms=50;settlingTime_ms=200;updateDelay=0
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: EFFECTENGINE INFO: 27 effects loaded from directory /usr/share/hyperion/effects
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: EFFECTENGINE INFO: Initializing Python interpreter
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: Hyperion started and initialised
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: Boot sequence 'Rainbow swirl fast' EFFECTENGINE INFO: run effect Rainbow swirl fast on channel 0
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: started
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: Json server created and started on port 19444
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: Proto server created and started on port 19445
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: V4L2GRABBER INFO: width=720 height=576
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: V4L2GRABBER INFO: pixel format=YUYV
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: BLACKBORDER INFO: threshold set to 0.18 (46)
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: BLACKBORDER INFO: mode:default
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: V4L2GRABBER INFO: signal threshold set to: {0,0,0}
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: V4L2GRABBER INFO: started
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: INFO: V4L2 grabber created and started
    ssh in:     Dec 02 09:34:46 hyperionsawzraspi hyperiond[13130]: V4L2GRABBER INFO: stopped
    ssh in:     Dec 02 09:34:54 hyperionsawzraspi hyperiond[13130]: EFFECTENGINE INFO: effect finished
    ssh in:     Dec 02 09:34:54 hyperionsawzraspi hyperiond[13130]: V4L2GRABBER INFO: started
    ssh in:     Dec 02 09:34:55 hyperionsawzraspi hyperiond[13130]: BORDER SWITCH REQUIRED!!
    ssh in:     Dec 02 09:34:55 hyperionsawzraspi hyperiond[13130]: CURRENT BORDER TYPE: unknown=0 hor.size=0 vert.size=0
    

    hyperion service war irgendwie aus, habe in dann mit
    Code:
    sudo service hyperion start
    gestartet und mit
    Code:
    sudo service hyperion status
    sieht auch alles ok aus.
    leider leuchtet auch keine einzigste led. netzteil ist auch an (von den leds).

    nun weiß ich nicht mehr weiter. hoffe mir kann jemand helfen :)
    achja, falls irgendwelche infos fehlen, bitte sagen, ich trage sie dann nach.
    wie gesagt, hat alles funktioniert und am nächsten tag ging gar nichts mehr...

    lg

    //edit: als ich die fotos gemacht habe, sah ich, wie plötzlich vereinzelnd an dem ersten und an dem letzten stripe leds rot flackern. seitlich und oben sind alle dunkel. strom habe ich beidseitig eingespeist, also an dem ersten und an dem letzten stripe.
    //edit2: was mir auch aufgefallen ist...an dem hdmi splitter bin ich vom odroidc2 mit hdmi in den eingang des splitters und dann jeweils vom ausgang an den tv und an den grabber. am splitter selber brennen an den ausgängen jeweils 1 rotes licht. am ausgang richtung tv brennt es durchgehend und am ausgang zum grabber blinkt es. aber ich hab keine ahnung, was das zu bedeuten hat.
     

    Attached Files:

  2. TaTuEe

    TaTuEe New Member

    Messages:
    6
    Hardware:
    RPi1/Zero
    Ich vermute dein HDMI to AV Konverter ist defekt (oder dieser bekommt nicht mehr ausreichend Strom)
     
  3. taker-`

    taker-` New Member

    Messages:
    13
    Hardware:
    RPi3, 32/64bit
    Aber wieso sollte es denn plötzlich zu wenig Strom bekommen?

    Hab es wieder ans laufen bekommen. Der hdmi splitter war defekt. Ich hatte einen mit USB Strom Versorgung und da habe ich gesehen, das das Kabel angekokelt war. Außerdem war ein 5v Kabel rausgerutscht. Habe wago klemmen benutzt... Dachte, das kann da nicht raus rutschen.

    Naja, ich werde am Wochenende die wago klemmen entfernen und alles löten.

    Jetzt habe ich aber noch ne frage. Hatte einen verstärker mit hdmi Eingängen und nem Ausgang. Vom Ausgang bin ich dann mit dem hdmi splitter dran. So hab ich 'alle' angeschlossenen Geräte mit ambilight gehabt.

    Der avr is kaputt und nun hab ich übergangsweise nen älteren ohne hdmi am laufen.

    Könnte ich nun theoretisch ein hdmi switch einsetzen, damit wieder alles funktioniert? Sollte doch gehen, oder nicht?

    Lg
     
  4. TaTuEe

    TaTuEe New Member

    Messages:
    6
    Hardware:
    RPi1/Zero
    Ich lese immer wieder, das die HDMI to AV Konverter regelmäßig ihren Geist aufgeben. Einige legen sich von den Konvertern mehrere zur Seite. Mein Konverter hat vor kurzem auch aus heiterem Himmel seinen Geist aufgegeben. Seit dem versuche ich einen zu finden der funktioniert, ich wusste gar nicht das das so schwer sein kann, weil man nie weiß was im Inneren verbaut wurde. Mein defekter Konverter sieht von außen aus genau ist wie dein Konverter, äußerlich habe ich genau den wieder bestellt und funktioniert nicht! Das war also Zufall, dass ich vor zwei Jahren einen Erwischt habe der funktioniert hat. Wie gesagt, das war nur eine Vermutung. Schön, wenn es bei Dir wieder funktioniert.
     
  5. taker-`

    taker-` New Member

    Messages:
    13
    Hardware:
    RPi3, 32/64bit
    Da hast du wohl recht. Ich hab bei meinem converter auch was seltsames gesehen. Ich bin mir zu 100% sicher, daß da ein blaues Licht an war... Eben das er 'an' ist. Nun ist kein blaues Licht mehr da, aber es funktioniert
     
  6. TaTuEe

    TaTuEe New Member

    Messages:
    6
    Hardware:
    RPi1/Zero
    Das ist lustig ;-) genau das kann ich auch bestätigen, der alte Konverter (der funktioniert hat und jetzt defekt ist) hatte bei mir auch ein blaues Licht, der neue (äußerlich baugleiche Konverter) hat kein blaues Licht mehr. Komisch ...., weil es ist auch keine Diode zu sehen.

    PS. Eigentlich ist dein Problem gelöst oder?
     
  7. taker-`

    taker-` New Member

    Messages:
    13
    Hardware:
    RPi3, 32/64bit
    Haha ja ^^
    Naja egal. Nun funktioniert es ja.

    Jap, problem ist gelöst