1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hyperion.ng

Discussion in 'Archive' started by nicedevil007, 26 September 2019.

Thread Status:
Not open for further replies.
  1. nicedevil007

    nicedevil007 New Member

    Messages:
    15
    Hardware:
    RPi3, +nodeMCU/ESP8266
    Hey Guys,

    because my "normal" installation of hyperion isn't working right now on my dietpi (raspbian buster) I gave hyperion.ng a try :)

    I'm running docker on my Pi as well for some server services like pihole or node-red. So I took the "automate script" to create/compile hyperion.ng on my pi with the buster version.

    After that I made the installation with dpkg -i Hyperion.....deb

    The shell tells me things like this and I don't know where to debug now :(

    upload_2019-9-26_22-5-13.png

    can someone help me out? Thank you in advance.
     
  2. Akriss

    Akriss Active Member

    Messages:
    567
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
    • Thank you Thank you x 1
  3. nicedevil007

    nicedevil007 New Member

    Messages:
    15
    Hardware:
    RPi3, +nodeMCU/ESP8266
    Hey Akriss,
    thanks for your answer. Unfurtunately I don't know how to install it the other way xD

    I have done the following steps:

    Code:
    sudo apt-get update
    sudo apt-get install git cmake build-essential qtbase5-dev libqt5serialport5-dev libusb-1.0-0-dev python3-dev libxrender-dev libavahi-core-dev libavahi-compat-libdnssd-dev libjpeg-dev libqt5sql5-sqlite libraspberrypi-dev -y
    
    wget -qO- https://raw.githubusercontent.com/hyperion-project/hyperion.ng/master/bin/compile.sh | sh
    but where is the deb file for installation located?

    I just was able to start hyperion with that command:

    Code:
    sudo hyperiond
    [hyperiond DISPMANXGRABBER] <ERROR> Failed to open display! Probably no permissions to access the capture interface
    
    but as you can see... error again with the dispmanxgrabber :/

    Code:
    # lsusb
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 004: ID 1b71:3002 Fushicai USBTV007 Video Grabber [EasyCAP]
     
    Last edited: 27 September 2019
  4. nicedevil007

    nicedevil007 New Member

    Messages:
    15
    Hardware:
    RPi3, +nodeMCU/ESP8266
    mhhhh ok... didn't test the homepage xD

    will test to get it to work:

    upload_2019-9-27_18-39-3.png
     
  5. nicedevil007

    nicedevil007 New Member

    Messages:
    15
    Hardware:
    RPi3, +nodeMCU/ESP8266
    Ok... configured everything but no LED will light up :/

    What else can be done to debug it?
     
  6. nicedevil007

    nicedevil007 New Member

    Messages:
    15
    Hardware:
    RPi3, +nodeMCU/ESP8266
    ok fogot it.... after trying out multiple OS for that... I forgot the dtparm thing on the last... now it is working <3
     
    • Like Like x 1
  7. nicedevil007

    nicedevil007 New Member

    Messages:
    15
    Hardware:
    RPi3, +nodeMCU/ESP8266
    could somebody be so kind to tell how to install hyperiond as service aftger compiling it without docker?
    just for now I'm going the wrong way I guess => cronjob with @reboot sleep 120; script.sh
     
  8. Akriss

    Akriss Active Member

    Messages:
    567
    Hardware:
    RPi1/Zero, RPi2, RPi3, 32/64bit, +Arduino, +nodeMCU/ESP8266
Thread Status:
Not open for further replies.