1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ISSUE Problem getting ambilight to work

Discussion in 'Software Support' started by Soundcrusher, 5 October 2020.

  1. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    Hello,


    Incredible noob here, never tried anything like this but am willing to learn with help of tutorials.


    I have been trying to get my WS2812b LED's to work like ambilight on my tv. I have been following multiple tutorials on the internet but can't get it to work. I have started to follow this tutorial: https://hyperion-project.org/threads/diy-amblight-project-guide-hyperion-ws2801-ws2812b-apa102.8/

    I started in August 2020 and needed to wait untill I have all the hardware. Now I have everything I need but the link above doesn't work anymore and can't complete this tutorial.

    I have also followed:

    https://forum.team-mediaportal.com/...-guide-hyperion-ws2801-ws2812b-apa102.128526/

    this link and the site/files from Christian Moser


    The main problem now is when I list my connected USB devices using SSH through PUTTY it won't recognize my videograbber in the way it is described in the Christian Moser files. When I power everything on I see the boot sequence (LED’s flashing red-green-blue) but after that nothing happens. I see the OpenElec logo after which it goes black (as it is supposed to I guess since according to the tutorial OpenElec auto-shutsdown because I don’t need it)


    The hardware I own is:

    - Mibox 4

    - Raspberry pi zero

    - Lightbox dream color (https://tinyurl.com/y53d594y), which is, as far as i know, an pre-programmed arduino

    - 4.5m WS2812b LED lights

    - Video grabber with on the chip: UTV007

    - HDMI splitter

    - HDMI to AV box

    - USB hub

    - USB to ethernet to get internet on my Pi Zero

    - HDMI cables

    I have set the hardware above up according to the tutorials. And am using OpenElec

    So the main problem right now is:

    - why does my Pi not recognize the video grabber

    - Is the lightbox dream color indeed a well programmed arduino

    - Can I re-acces the first hyperion link since that was the best tutorial so far which I started but now cannot finish.

    If needed I ofcourse can provide any SSH data if necessary.

    Kind regards in advance!
     
  2. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,886
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    the tutorial you linked, is based on the old hyperion..(classic) which is discontinued...
    you should have a look on hyperion.ng
    try this one
     
  3. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    Awesome, thanks. WIll need to order some new things but I will give this a try!
     
  4. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,886
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    should work with your acutall hardware too, give it a try...
     
  5. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    Allright, so when using a Pi Zero I guess nothing changes and I need to connect the LED's to GPIO18 as well?
    My LED strip has a connector to go in the lightbox/arduino case, is it possible to cut this connector and solder a simple wire from the LED data pin to the GPIO18? Or is it easier to leave this pre-solderd connector and just solder a data wire to the free end of the LED strip and set the data in the software to go counterclockwise instead of clockwise as it is going right now?
     
  6. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    To clarify with a picture:

    On the right is the beginning of the LED strip with a power and a data connector. On the left is the end of the LED strip with an extra power connector clipped on. Is it possible to wire the GPI0 18 port to the data connector on the end of the LED strip so I can leave the pre-soldered cables on? And I guess i need to reverse the data flow in this case

    [​IMG]
    [​IMG]
     
  7. TPmodding

    TPmodding Administrator Staff Member Administrator

    Messages:
    1,886
    Hardware:
    RPi1/Zero, RPi2, RPi3, +Arduino, +nodeMCU/ESP8266
    no...there is an arrow on the stripe, which shows you the direction of the data signal..it can only go in one direction....
     
  8. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    ah okay thanks!, then I will re-solder the connectors at the beginning
     
  9. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    I have everything set up according to the youtube video but so far no succes. I can acces Hyperion through my browser and have set everything as instructed in the video. I don't get the lights to light up on booting the raspberry. Today I got my Pi Zero W and the wireless connection works great.
    Is there an other way to test the LED's?
     
  10. Lord-Grey

    Lord-Grey Moderator Staff Member Developer

    Messages:
    256
    Hardware:
    RPi3, 32/64bit
    @Soundcrusher You might have a lock into hyperion's log (System->Log), if there are any Errors reported.
     
  11. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    Edit:

    I changed the log-level to debug and got this:

    Code:
     2020-10-07T19:19:02.894Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:204:sendClose()) send close: 1000
    2020-10-07T19:19:04.890Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.0.109
    2020-10-07T19:19:04.908Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.0.109' switch to Hyperion instance 0
    2020-10-07T19:19:07.718Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1032:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.0.109
    2020-10-07T19:19:07.767Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1041:handleLoggingCommand()) log streaming deactivated for client  ::ffff:192.168.0.109
    2020-10-07T19:19:42.898Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.0.109
    2020-10-07T19:19:42.908Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.0.109' switch to Hyperion instance 0
    2020-10-07T19:19:45.762Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1032:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.0.109
    2020-10-07T19:19:45.797Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1041:handleLoggingCommand()) log streaming deactivated for client  ::ffff:192.168.0.109
    2020-10-07T19:22:41.179Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:204:sendClose()) send close: 1000
    2020-10-07T19:22:43.793Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.0.109
    2020-10-07T19:22:43.804Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.0.109' switch to Hyperion instance 0
    2020-10-07T19:22:46.662Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1032:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.0.109
    All the other log-levels gave: No log messages available.
     
    Last edited: 7 October 2020
  12. Lord-Grey

    Lord-Grey Moderator Staff Member Developer

    Messages:
    256
    Hardware:
    RPi3, 32/64bit
    Could enable the debug log and then disable and then enable the LedDevice via the „Remote Control“ and share the log output again?

    Via „Remote Control“ you can also set a solid color. Does the LEDs light up in the color?
     
  13. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    How can I enable/disable in the Remote Control tab? I don't see anything where I can do that.

    When I select anything in the colour/effects tab, should this effect start right away?

    Edit: This is wat it says at 'Remote Control'

    https://ibb.co/CwVtML4

    (sorry, can't post the screenshot somehow)
     
    Last edited: 7 October 2020
  14. Lord-Grey

    Lord-Grey Moderator Staff Member Developer

    Messages:
    256
    Hardware:
    RPi3, 32/64bit
    use the on/off switch Button next to LEDDevice.

    yes
     
  15. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    Thanks, when selecting something at the colour/effects button nothing happens. I enabled and disabled and now have this debug log:

    Code:
    020-10-07T19:33:42.750Z [hyperiond DAEMON] (INFO) CEC handler created
    2020-10-07T19:33:42.822Z [hyperiond EFFECTFILES] (INFO) 39 effects loaded from directory :/effects/
    2020-10-07T19:33:42.848Z [hyperiond EFFECTFILES] (INFO) 22 effect schemas loaded from directory :/effects/schema/
    2020-10-07T19:33:42.852Z [hyperiond EFFECTFILES] (INFO) 0 effects loaded from directory /root/.hyperion/custom-effects
    2020-10-07T19:33:43.211Z [hyperiond SETTINGSMGR] (DEBUG) (SettingsManager.cpp:107:SettingsManager()) Settings database initialized
    2020-10-07T19:33:43.234Z [hyperiond BLACKBORDER] (DEBUG) (BlackBorderProcessor.cpp:64:handleSettingsUpdate()) Set mode to: default
    2020-10-07T19:33:43.237Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Blackborder detector: enabled
    2020-10-07T19:33:45.009Z [hyperiond DAEMON] (INFO) set screen capture device to 'dispmanx'
    2020-10-07T19:33:45.020Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0
    2020-10-07T19:33:45.041Z [hyperiond DISPMANXGRABBER] (INFO) Display opened with resolution: 720x480
    2020-10-07T19:33:45.047Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:90:setWidthHeight()) Set new width: 80, height: 45 for capture
    2020-10-07T19:33:45.058Z [hyperiond DAEMON] (INFO) DISPMANX frame grabber created
    2020-10-07T19:33:45.083Z [hyperiond V4L2:AUTO] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0
    2020-10-07T19:33:45.097Z [hyperiond V4L2:AUTO] (INFO) Signal threshold set to: {12, 12, 12}
    2020-10-07T19:33:45.108Z [hyperiond V4L2:AUTO] (INFO) CEC detection is now disabled
    2020-10-07T19:33:45.112Z [hyperiond V4L2:AUTO] (INFO) Signal detection is now disabled
    2020-10-07T19:33:45.118Z [hyperiond V4L2:AUTO] (INFO) Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000
    2020-10-07T19:33:45.121Z [hyperiond DAEMON] (DEBUG) (hyperiond.cpp:568:handleSettingsUpdate()) V4L2 grabber created
    2020-10-07T19:33:45.126Z [hyperiond JSONSERVER] (DEBUG) (JsonServer.cpp:27:JsonServer()) Created instance
    2020-10-07T19:33:45.136Z [hyperiond JSONSERVER] (INFO) Started on port 19444
    2020-10-07T19:33:45.043Z [hyperiond LEDDEVICE] (INFO) Start LedDevice 'ws281x'.
    2020-10-07T19:33:45.037Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Smoothing: enabled
    2020-10-07T19:33:45.054Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:147:init()) deviceConfig: [{"colorOrder":"rgb","currentLedCount":270,"dma":5,"gpio":18,"hardwareLedCount":270,"invert":false,"latchTime":0,"leds":276,"pwmchannel":0,"rewriteTime":1000,"rgbw":false,"type":"ws281x","whiteAlgorithm":"subtract_minimum"}]
    2020-10-07T19:33:45.066Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:403:setLatchTime()) LatchTime updated to 0ms
    2020-10-07T19:33:45.078Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:423:setRewriteTime()) Refresh interval = 1000ms
    2020-10-07T19:33:45.084Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:429:setRewriteTime()) RewriteTime updated to 1000ms
    2020-10-07T19:33:45.087Z [hyperiond LEDDEVICE] (DEBUG) (LedDeviceWS281x.cpp:59:init()) ws281x strip type : 1050624
    2020-10-07T19:33:45.115Z [hyperiond FLATBUFCONN] (INFO) Connecting to Hyperion: 127.0.0.1:19401
    2020-10-07T19:33:45.134Z [hyperiond EFFECTENGINE] (INFO) Run effect "Rainbow swirl fast" on channel 0
    2020-10-07T19:33:45.151Z [hyperiond FLATBUFSERVER] (INFO) Started on port 19400
    2020-10-07T19:33:45.155Z [hyperiond PROTOSERVER] (INFO) Started on port 19445
    2020-10-07T19:33:45.166Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:32:initServer()) Initialize Webserver
    2020-10-07T19:33:45.168Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:32:initServer()) Initialize Webserver
    2020-10-07T19:33:45.246Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Rainbow swirl fast], smoothCfg [2]
    2020-10-07T19:33:45.249Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'System/EFFECT' with priority 0 as inactive
    2020-10-07T19:33:45.252Z [hyperiond HYPERION] (INFO) Initial foreground effect 'Rainbow swirl fast' started
    2020-10-07T19:33:45.256Z [hyperiond EFFECTENGINE] (INFO) Run effect "Warm mood blobs" on channel 254
    2020-10-07T19:33:45.267Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Warm mood blobs], smoothCfg [2]
    2020-10-07T19:33:45.278Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'System/EFFECT' with priority 254 as inactive
    2020-10-07T19:33:45.281Z [hyperiond HYPERION] (INFO) Inital background effect 'Warm mood blobs' started
    2020-10-07T19:33:45.289Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'System/V4L' with priority 240 as inactive
    2020-10-07T19:33:45.300Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) V4L capture device: enabled
    2020-10-07T19:33:45.314Z [hyperiond V4L2:AUTO] (INFO) available V4L2 devices:
        /dev/video14    bcm2835-isp-capture0
        /dev/video15    bcm2835-isp-capture1
    
    2020-10-07T19:33:45.325Z [hyperiond V4L2:AUTO] (INFO) search for usable video devices
    2020-10-07T19:33:45.344Z [hyperiond V4L2:AUTO] (INFO) test v4l device: /dev/video14
    2020-10-07T19:33:45.358Z [hyperiond V4L2:AUTO] (DEBUG) (V4L2Grabber.cpp:696:init_device()) Set resolution to width=1280 height=1280
    2020-10-07T19:33:45.362Z [hyperiond V4L2:AUTO] (DEBUG) (V4L2Grabber.cpp:735:init_device()) Pixel format=YUYV
    2020-10-07T19:33:45.418Z [hyperiond V4L2:AUTO] (INFO) found usable v4l2 device: /dev/video14 (bcm2835-isp-capture0)
    2020-10-07T19:33:45.432Z [hyperiond V4L2:AUTO] (INFO) Started
    2020-10-07T19:33:45.434Z [hyperiond V4L2:auto] (DEBUG) (GrabberWrapper.cpp:48:start()) Grabber start()
    2020-10-07T19:33:45.321Z [hyperiond BOBLIGHT] (DEBUG) (BoblightServer.cpp:28:BoblightServer()) Instance created
    2020-10-07T19:33:45.449Z [hyperiond HYPERION] (INFO) Hyperion instance 'GPIO-18' has been started
    2020-10-07T19:33:45.334Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled
    2020-10-07T19:33:45.572Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 0
    2020-10-07T19:33:45.575Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[0], previousPriority[255]
    2020-10-07T19:33:45.578Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:548:handlPriorityChangedLedDevice()) new source available -> switch LED-Device on
    2020-10-07T19:33:45.626Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:90:handleSettingsUpdate()) Apply Webserver settings
    2020-10-07T19:33:45.629Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:108:handleSettingsUpdate()) Set document root to: :/webconfig
    2020-10-07T19:33:45.629Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:90:handleSettingsUpdate()) Apply Webserver settings
    2020-10-07T19:33:45.634Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:108:handleSettingsUpdate()) Set document root to: :/webconfig
    2020-10-07T19:33:45.646Z [hyperiond WEBSERVER] (INFO) Started on port 8090 name 'Hyperion Webserver'
    2020-10-07T19:33:45.720Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:174:handleSettingsUpdate()) Setup SSL certificate
    2020-10-07T19:33:45.726Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:190:handleSettingsUpdate()) Setup private SSL key
    2020-10-07T19:33:45.739Z [hyperiond WEBSERVER] (INFO) Started on port 8092 name 'Hyperion Webserver'
    2020-10-07T19:33:46.964Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:238:setInputImage()) Priority 0 is now active
    2020-10-07T19:33:47.357Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:198:setInput()) Priority 254 is now active
    2020-10-07T19:33:47.974Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.0.109
    2020-10-07T19:33:47.985Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.0.109' switch to Hyperion instance 0
    2020-10-07T19:33:49.068Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:298:setCurrentTime()) Timeout clear for priority 0
    2020-10-07T19:33:49.318Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:33:49.321Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[0]
    2020-10-07T19:36:58.702Z [hyperiond EFFECTENGINE] (INFO) Run effect "Lights" on channel 1
    2020-10-07T19:36:58.708Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Lights], smoothCfg [2]
    2020-10-07T19:36:58.709Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'Web [email protected]::ffff:192.168.0.109/EFFECT' with priority 1 as inactive
    2020-10-07T19:36:59.218Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:238:setInputImage()) Priority 1 is now active
    2020-10-07T19:36:59.220Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 1
    2020-10-07T19:36:59.228Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[1], previousPriority[254]
    2020-10-07T19:37:07.547Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:255:clearInput()) Removed source priority 1
    2020-10-07T19:37:07.552Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:37:07.556Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[1]
    2020-10-07T19:37:07.673Z [hyperiond EFFECTENGINE] (INFO) Run effect "Lights" on channel 1
    2020-10-07T19:37:07.675Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Lights], smoothCfg [2]
    2020-10-07T19:37:07.678Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'Web [email protected]::ffff:192.168.0.109/EFFECT' with priority 1 as inactive
    2020-10-07T19:37:08.239Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:238:setInputImage()) Priority 1 is now active
    2020-10-07T19:37:08.252Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 1
    2020-10-07T19:37:08.257Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[1], previousPriority[254]
    2020-10-07T19:37:08.265Z [hyperiond EFFECTENGINE] (INFO) effect finished
    2020-10-07T19:37:18.092Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:298:setCurrentTime()) Timeout clear for priority 1
    2020-10-07T19:37:18.097Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:37:18.098Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[1]
    2020-10-07T19:37:31.638Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'Web [email protected]::ffff:192.168.0.109/COLOR' with priority 1 as inactive
    2020-10-07T19:37:31.651Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:198:setInput()) Priority 1 is now active
    2020-10-07T19:37:31.654Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 1
    2020-10-07T19:37:31.662Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[1], previousPriority[254]
    2020-10-07T19:37:32.149Z [hyperiond EFFECTENGINE] (INFO) effect finished
    2020-10-07T19:37:41.842Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:298:setCurrentTime()) Timeout clear for priority 1
    2020-10-07T19:37:41.849Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:37:41.853Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[1]
    2020-10-07T19:37:50.945Z [hyperiond BLACKBORDER] (DEBUG) (ImageProcessor.cpp:111:setLedMappingType()) set user led mapping to unicolor_mean
    2020-10-07T19:37:56.151Z [hyperiond BLACKBORDER] (DEBUG) (ImageProcessor.cpp:111:setLedMappingType()) set user led mapping to multicolor_mean
    2020-10-07T19:46:19.050Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: disabled
    2020-10-07T19:46:20.135Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled
    2020-10-07T19:46:26.432Z [hyperiond EFFECTENGINE] (INFO) Run effect "Led Test" on channel 1
    2020-10-07T19:46:26.436Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Led Test], smoothCfg [2]
    2020-10-07T19:46:26.437Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'Web [email protected]::ffff:192.168.0.109/EFFECT' with priority 1 as inactive
    2020-10-07T19:46:26.713Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:198:setInput()) Priority 1 is now active
    2020-10-07T19:46:26.716Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 1
    2020-10-07T19:46:26.722Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[1], previousPriority[254]
    2020-10-07T19:46:29.940Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: disabled
    2020-10-07T19:46:30.855Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled
    2020-10-07T19:46:36.842Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:298:setCurrentTime()) Timeout clear for priority 1
    2020-10-07T19:46:36.849Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:46:36.853Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[1]
    2020-10-07T19:46:51.437Z [hyperiond EFFECTENGINE] (INFO) Run effect "Strobe red" on channel 1
    2020-10-07T19:46:51.442Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Strobe red], smoothCfg [2]
    2020-10-07T19:46:51.445Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'Web [email protected]::ffff:192.168.0.109/EFFECT' with priority 1 as inactive
    2020-10-07T19:46:51.547Z [hyperiond EFFECTENGINE] (INFO) effect finished
    2020-10-07T19:46:51.878Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:198:setInput()) Priority 1 is now active
    2020-10-07T19:46:51.881Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 1
    2020-10-07T19:46:51.887Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[1], previousPriority[254]
    2020-10-07T19:46:53.068Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:255:clearInput()) Removed source priority 1
    2020-10-07T19:46:53.072Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:46:53.075Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[1]
    2020-10-07T19:46:53.685Z [hyperiond EFFECTENGINE] (INFO) effect finished
    2020-10-07T19:47:03.585Z [hyperiond EFFECTENGINE] (INFO) Run effect "Rainbow swirl" on channel 1
    2020-10-07T19:47:03.593Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Rainbow swirl], smoothCfg [2]
    2020-10-07T19:47:03.594Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:159:registerInput()) Register new input 'Web [email protected]::ffff:192.168.0.109/EFFECT' with priority 1 as inactive
    2020-10-07T19:47:04.344Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:238:setInputImage()) Priority 1 is now active
    2020-10-07T19:47:04.346Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 1
    2020-10-07T19:47:04.354Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[1], previousPriority[254]
    2020-10-07T19:47:07.806Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: disabled
    2020-10-07T19:47:08.540Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled
    2020-10-07T19:47:13.842Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:298:setCurrentTime()) Timeout clear for priority 1
    2020-10-07T19:47:13.848Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:333:setCurrentTime()) Set visible priority to 254
    2020-10-07T19:47:13.849Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:538:handlPriorityChangedLedDevice()) priority[254], previousPriority[1]
    2020-10-07T19:47:36.299Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1032:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.0.109
    2020-10-07T19:47:36.437Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1041:handleLoggingCommand()) log streaming deactivated for client  ::ffff:192.168.0.109
    2020-10-07T19:47:39.312Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:204:sendClose()) send close: 1000
    2020-10-07T19:47:40.898Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:192.168.0.109
    2020-10-07T19:47:40.913Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:192.168.0.109' switch to Hyperion instance 0
    2020-10-07T19:47:43.854Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1032:handleLoggingCommand()) log streaming activated for client ::ffff:192.168.0.109
     
  16. Lord-Grey

    Lord-Grey Moderator Staff Member Developer

    Messages:
    256
    Hardware:
    RPi3, 32/64bit
    Unfortunately, I do not see that you disabled or enabled the device in the log.
    Nevertheless, I do not see any previous errors for the LED Device. Looks like that it is more hardware related....
     
  17. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    Hmm strange, somehow I also think it is hardware related.

    I just got a new Pi Zero W today so that should be okay. The lighting on the back of my tv have worked before so I know they aren't broken.
    The other thing I changed is the input side of the LED strip, it had 2 connectors; one for the 5V power block, and one which goes in the arduino I got by the set I bought on Aliexpress but don't use right now. I took off both connectors, solderd a red wire to the + and black to the ground which go to the original connector and to the power block.
    The other connector is gone and I have solderd a small wire to the data point on the LED strip and the other side to the GPIO-18 port of my raspberry, could this be the source of the trouble? Is this one small wire enough?
     

    Attached Files:

    • led.jpg
      led.jpg
      File size:
      1.1 MB
      Views:
      26
    Last edited: 7 October 2020
  18. Soundcrusher

    Soundcrusher New Member

    Messages:
    16
    Hardware:
    RPi1/Zero
    I'm at a loss. I re-solderd everything, now the leds do kinda light up but it is like a Christmas tree, very unstable, a lot of flickering and differently coloured led's even though there shouldn't be any led's on since I shut down everything in the browser. I'm still using the same 5V8A block I used before and worked great so the amps are high enough
     
    Last edited: 8 October 2020
  19. harun

    harun Hyperion-Fool

    Messages:
    236
    Hardware:
    RPi3
    Try another power supply
     
  20. Lord-Grey

    Lord-Grey Moderator Staff Member Developer

    Messages:
    256
    Hardware:
    RPi3, 32/64bit
    Do you have installed the latest Hyperion.NG version, I.e. Alpha8?