1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperCon Sk6812 strip - Does anybody have this led strip and is working? What is your setup? (help needed)

Discussion in 'Software Support' started by Simona, 20 October 2020.

  1. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    I have lights WS2812b (5M) + RP B+ and grabber V4L2 on Openelec 8.0.4. Everything was working ok for few months. Now when I turn on ambilight lights are working for sam time ok (different time, some time 5 minutes - sometime hour), and then they freeze on the left side of the TV (from approx. 185 led till the end of strip 271. ) After that left side won't work anymore, sometime freezzes on last color sometimes on black. The right side working ok. If I turn of light and turno back again it is not helping. I must wait with turned off for approx. 10min, then I turn them again and is working for some time and again freezes. It is driving me crazy.


    Can you please help me what is wrong with my setup? Thank you!

    EDIT:

    I bought new led strip. Now I have sk6812 with neutral white, but now is not working last 60 lights and on others color is not ok. Almost all the lights are shinning only white.

    Led SK6812 RGBneutral white
    Raspberry B+
    Ambibox dreamcolor
    Grabber V4L2
    all on Hyperbian.

    Last 60leds dont work, others shine white mixed with color, lights are moving with picuture, but all seems white. When I try to get only one color with color wheel on my phone, they are changing to color - again white mixed with color.

    What I did wrong?
     
    Last edited: 31 October 2020
  2. pclin

    pclin Active Member

    Messages:
    402
    Hardware:
    +nodeMCU/ESP8266
    I don't think it's your setup. Either the LED where the problem starts, or the connection.
    Check if there is a solder connection in the stripe.
    That could be a temperature problem, resistance or something similar.

    Regards pclin
     
    Last edited: 20 October 2020
  3. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    I bought new led strip. Now I have sk6812 with neutral white, but now is not working last 60 lights and on others color is not ok. Almost all the lights are shinning only white.
     
  4. harun

    harun Hyperion-Fool

    Messages:
    239
    Hardware:
    RPi3
    Openelec is old. Try libreelec to test it.
     
  5. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    I use Hyperbian now and have this problems. And if I use Hyperion on my phone and choose only red or some other color, they shine white again.
     
  6. harun

    harun Hyperion-Fool

    Messages:
    239
    Hardware:
    RPi3
    Maybe the strip is the problem. Maybe you bought a white strip and not rgb
     
  7. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    No, it is RGB with neutral white . Every second light is shinnig in color.

    Now, my setup has new lights, and I don’t know how to make them work:

    Led SK6812 RGBneutral white
    Raspberry B+
    Ambibox dreamcolor
    Grabber V4L2
    all on Hyperbian.

    Last 60leds dont work, others shine white mixed with color, lights are moving with picuture, but all seems white. When I try to get only one color with color wheel on my phone, they are changing to color - again white mixed with color.

    On settings I use adalight (115200 baudrate), If i change anything lights go off.

    Thank you for your help!
     
    Last edited: 29 October 2020
  8. harun

    harun Hyperion-Fool

    Messages:
    239
    Hardware:
    RPi3
    I can not help you. My setup is different components. Maybe someone else could help you further buddy.
     
  9. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    Ok, thank you for your respond ;). Hope someone can help.
     
  10. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    Anybody knows this? Struggling for days now and can't find how to resolve problem. Do I have to buy different lights or..?
     
  11. pclin

    pclin Active Member

    Messages:
    402
    Hardware:
    +nodeMCU/ESP8266
    I think Ambibox dreamcolor doesn't support RGBW stripes.
    Use Wemos mini D1 with WLED software.

    Regards pclin
     
  12. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    Thank you, will order Wemos then, do I need anything more ?
     
  13. pclin

    pclin Active Member

    Messages:
    402
    Hardware:
    +nodeMCU/ESP8266
    Take a look at the WLED-Wiki.
    Actually, you don't need anything anymore, maybe a Level Shifter.

    Regards pclin
     
  14. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
  15. pclin

    pclin Active Member

    Messages:
    402
    Hardware:
    +nodeMCU/ESP8266
    I use 268 led and it is enough to supply at both ends.

    Regards pclin
     
  16. Simona

    Simona simtaj

    Messages:
    13
    Hardware:
    RPi2
    Sorry my mistake, now I se that mine is 5V 8A, is it still enough ? And which type of level shifter you suggest ?
     
  17. pclin

    pclin Active Member

    Messages:
    402
    Hardware:
    +nodeMCU/ESP8266
    5V 15A would be better for for brightest white.
    With WLED you can also limit that to 8A.

    Regards pclin
     

    Attached Files:

  18. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / WS2801 / Hyperion.NG

    Messages:
    128
    Hardware:
    RPi3
    i suggest that you measure the voltage on the supply, it has to be 5 volts exact (under load)> everything more will hurt the lights over time, everything less will downgrade the datalines
     
  19. jeroen warmerdam

    jeroen warmerdam Raspberry 3B / APA102 / WS2801 / Hyperion.NG

    Messages:
    128
    Hardware:
    RPi3
    you can connect the lights directly to the GPIO pins ( SPI device) of the PI > its for 95% of the time no problem and will work. Ground everything to each other so pi to ledstrip/ ledstrip to powersupply/ powersupply to PI. Without a levelshifter it can work, the GPIO is able to put out 3,3 volts of dataline while the ledstrip wants to have 3.5 volts.